矩阵乘法

“简单”的矩阵乘法

矩阵乘法,就是将两个矩阵相乘

EThWN.png

现要求写一个程序,可以实现矩阵相乘。

输入格式

第一行三个正整数 n p m ,表示矩阵的长宽。
之后的 n 行,每行 p 个整数,表示矩阵 A
之后的 p 行,每行 m 个整数,表示矩阵 B

输出格式

输出 n 行,每行 m 个整数,表示矩阵 A×B ,每个数模 10 ^ 9 + 7 输出。

输入样例

1
2
3
4
5
6
7
8
3 4 5
-2 -8 -9 8
-10 0 6 -8
-10 -6 6 9
4 -7 5 -5 9
10 -2 -10 5 5
-3 -7 -3 8 -2
-6 7 7 3 -2

良心数据

输出样例

1
2
3
999999898 149 153 999999929 999999951
999999997 999999979 999999883 74 999999921
999999835 103 55 95 999999857

代码实现

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

typedef long long LL;

const int maxn = 505;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;

struct Matrix{
LL arr[maxn][maxn];
int n,m;
Matrix operator * (const Matrix &b)const{
// 重载运算符
Matrix res;
memset(res.arr,0,sizeof(res.arr));
for(int i = 0;i < n;i++)
for(int j = 0;j < b.m;j++)
for(int k = 0;k < m;k++){
(res.arr[i][j] += arr[i][k] * b.arr[k][j] % MOD) %= MOD;
}
res.n = n;res.m = b.m;
return res;
}
}a,b,ans;
// 用结构体来储存矩阵

int main(){

int n,p,m;

scanf("%d %d %d",&n,&p,&m);

a.n = n;a.m = p;

for(int i = 0;i < n;i++)
for(int j = 0;j < p;j++){
scanf("%lld",&a.arr[i][j]);
}
// 输入矩阵
b.n = p;b.m = m;

for(int i = 0;i < p;i++)
for(int j = 0;j < m;j++){
scanf("%lld",&b.arr[i][j]);
}

ans = a * b;

for(int i = 0;i < n;i++){
for(int j = 0;j < m - 1;j++){
(ans.arr[i][j] += MOD) %= MOD;
printf("%lld ",ans.arr[i][j]);
}
(ans.arr[i][m - 1] += MOD) %= MOD;
printf("%lld\n",ans.arr[i][m - 1]);
}
// 输出矩阵
return 0;
}
图片 by [simimg.com](https://simimg.com/)