洛谷P1879《[USACO06NOV]玉米田Corn Fields》

ProjectDP - 28

状压DP入门题

题目描述

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

输入输出格式

输入格式

第一行:两个整数M和N,用空格隔开。

第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

输出格式

一个整数,即牧场分配总方案数除以100,000,000的余数。

输入输出样例

输入样例

1
2
3
2 3
1 1 1
0 1 0

输出样例

1
9

解题思路

一道状压DP入门题

首先我们发现对于每一行,有 N 个状态
那么就意味着这是一个N + 1维DP……

但是我们发现从第二维到第N维都只需要0(不种玉米)和1(种玉米)两个值
那么……二进制!
比如 1010 就表示第1、3个格种玉米,第2、4个格不种玉米


f[i][\text{status}] 表示第 i 行种玉米的状态是 \text{status}
转移方程很显然吧

f[i][\text{status}] = f[i][\text{status}] + f[i - 1][ \text{pre_status}]

如何判断 \text{status} \text{pre_status} 是不是互相合法?


我们先来看看如何判断两行互相合法。

「合法」指两行种玉米的地方不相邻,也就是两个1不相邻。
我们来想想位运算 and 的性质

1
2
3
4
5
6
7
8
9
10
11
运算法则:
1 & 1 = 1
1 & 0 = 0
0 & 0 = 0

and (aka &) 是按位运算的
例如:
10101101 10100100
& 10110100 & 01010001
---------- ----------
10100100 00000000

我们发现,第二个例子放在题目中是合法的,它们进行 and 运算的值为 0
那么方法不就出来了吗!

1
2
3
bool Check(int stat1, int stat2) {
return (stat1 & stat2) == 0;
}

单行的状态也可能不合法,如何对敌怎么解决?

1
2
3
4
5
6
7
8
9
10
11
stat1 = 01001101 就是一个不合法的状态
我们把 stat1 左移一位( stat1 = stat1 << 1 )
得到了 stat2 = 10011010

我们把他们 and 一下

01001101
& 10011010
----------
00001000 > 0

那么方法就出来了

1
2
3
bool CheckSingleLine(int stat) {
return Check(stat, stat << 1);
}

之后处理一下土地的状态

我们将一行土地的利用情况记为二进制
0表示荒地,1表示耕地

我们判断一下当前状态与利用情况 and 起来是否还等于当前状况即可
正确性证明留作习题


那么我们枚举所有的可能状态,挨个判断即可。
注意边界条件 f[0][0] = 1

代码实现

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
//
// 28.cpp
// ProjectDP
//
// Created by HandwerSTD on 2019/1/29.
// Copyright © 2019 Handwer STD. All rights reserved.
//

#include <iostream>
#include <vector>

#define FILE_IN(__fname) freopen(__fname, "r", stdin)
#define FILE_OUT(__fname) freopen(__fname, "w", stdout)
#define IMPROVE_IO() std::ios::sync_with_stdio(false)
#define Stat(__x) FIXED_STATUS[__x]

using std::cin;
using std::cout;
using std::endl;

const int MAXSTATUS = (1 << 12) - 1 + 10;
const int MAXMN = 12 + 5;
const int HA = 100000000;

int m, n;
int farm[MAXMN][MAXMN];
int dp[MAXMN][MAXSTATUS], FIXED_STATUS[MAXSTATUS];

/*
*
* dp[i][stat]: line = i, status = stat (binary)
*
*/

int main() {
IMPROVE_IO();
cin >> m >> n;
for (int i = 1; i <= m; ++i) {
for (int j = 1; j <= n; ++j) {
cin >> farm[i][j];
Stat(i) = (Stat(i) << 1) + farm[i][j]; // 预处理一下土地的状态
}
}

dp[0][0] = 1;
for (int i = 1; i <= m; ++i) {
for (int status = 0; status <= (1 << n) - 1; ++status) {
if ((status & (status << 1)) != 0) continue;
// some grass are close to each other
if ((status & Stat(i)) != status) continue;
// at least one grass planted on a barren place
for (int pre_stat = 0; pre_stat <= (1 << n) - 1; ++pre_stat) {
if ((status & pre_stat) == 0) {
dp[i][status] += dp[i - 1][pre_stat];
dp[i][status] %= HA;
}
}
}
}
int ans = 0;
for (int i = 0; i <= (1 << n) - 1; ++i) {
ans += dp[m][i];
ans %= HA;
}
cout << ans << endl;
return 0;
}